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Welcome to TDM digital signage  

Thank you for your interest in TDM digital signage software. TDM is a cloud-based digital signage solution 
that can be fully managed and configured using your web browser. This manual is designed to assist users in 
a user-friendly way to install TDM on your computer or screen, and to publish content. 
 
Before we begin, we would like to let you know that we will be available to assist you at any time if you 
encounter any difficulties. We are here for you, regardless of whether you are a new or existing TDM user. 
Our contact details can be found on our website: http://www.tdmsignage.com/contact/ 
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Functions 
Function Player-

version [PC] 
Non-player 
version [HTML5] 

Android version 
[ANDROID] 

    

Video upload v x v 

Youtube v v v 

PDF integration v v v 

Powerpoint integration v v v 

Twitter integration v v v 

Instagram integration v v v 

Facebook integration v v v 

Websites v v v 

Flash v x x 

Silverlight v x x 

Streaming Video v v v 

Streaming Audio v v v 

Weather feed v v v 

Dynamic text v v v 

External data 
[RSS/XML] 

v v v 

Media RSS v v v 

TV-channels  (only with 
Sony) 

x v v 

Local caching* v x v 

Ticker tape v v v 

Plan module 
(scheduling) 

v v v 

Bandwith-efficiënt** v x v 

Monitoring v v v 

RS232 Commandos v x  

Touch functionality v v v 

Interactivity v v  

Spectator Statistics *** v x x 

Offline mode v x v 
 
 

 
 
*) Local caching is used to retrieve data from the server and save it to the local PC, so as to ensure that presentations can still be displayed even when 
your internet connection is down. Note: this does not apply to services such as audio and video streaming. 
**) The player is bandwidth-efficient because the data is retrieved from the TDM servers only once. The player version and Android app do not need 
to retrieve the content from the internet on each separate occasion, making it bandwidth-efficient. 
***) For the use of Spectator Statistics you need a full-hd camera, connected to your screen and player. Furthermore you need to 

download additional software from the download section in the TDM designer. TDM Spectator Statistics  licenses can be purchased 

through your reseller of distributor.  
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Creating presentations  
Before you start creating a presentation, you must inspect the following image and understand the 

hierarchy: 

 

After studying the image above, we understand that the presentation is made up out of one or multiple 
playlists. A playlist contains pages. These pages are based on templates, which are a blueprint for that 
specific page. Your corporate identity is guaranteed in the masterpage; this special template holds your 
company logo and elements in your corporate style and/or colours, for example.   
 
The presentation represents the final content you would like to display on a screen or multiple screens. 
Presentations are created from pages that are bases on either a standard or customised template.  
The easiest way to create your presentation is to use our Content Wizard. On the next pages, we explain how 
the wizard works. 
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Content wizard 
TDM offers a Content Wizard to help you understand the structure and work method of TDM. 
Start the wizard by clicking the Content wizard button. 

 

This button takes you to a summary screen which explains the wizard. Click the Start Wizard button to start 

the wizard. 
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After clicking the start wizard button, a new pop-up opens. In the first step you can provide a name for the 

items the wizard will create. Fill in your desired name and click Next. 

 

The next step asks you if you want to create a Masterpage. If you select NO this step will be skipped. 

 

if you select YES, the created masterpage will be shown. (We have in the example below!) 
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After clicking Next you get the opportunity to select and upload a logo to be added to your masterpage. 

 

After selecting your logo, or skipping the previous step, you can add a newsfeed for your tickertape. There is 

a default feed selected. After adding your newsfeed, or keeping the default feed you can click NEXT to 

advance. 
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The next screen presents you with some information about templates. Click the Next button to create your 

template. 
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The next screen shows you the template that was created in a preview. By clicking the NEXT button, a page 

will be created. 

 

In the next screen you can add a picture to be displayed in the right side of your page. After uploading a 

picture, you can add a Title and some Text. 

 

The next step tells you the wizard will create a playlist for you. The page created in the previous step will be 

added to the playlist. Click NEXT to advance to the following step. 



 

                                                                         
 

 

12 
 

 

 

In the next step, a presentation is created. Click NEXT to create your presentation and advance. 

 

After creating the presentation, you have to assign a player to the presentation. Select a desired player in the 

dropdown and click NEXT. 

 

You have now followed all the steps and your presentation is ready to be displayed. 
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Mail to Signage 

It is possible to setup an email account for receiving PowerPoint presentation. The PowerPoint will be 

automatically converted to a template, page, playlist and connected to a presentation. With this option it is 

possible to update and maintain your signage presentation without ever having to login. 

It is important to first create a presentation manually and connect a playlist and player to it. This will ensure 

the system know what presentation and player to use. After the first mail is send the playlist will be replaced 

by a new automatically created playlist. 

 

 

In this example we have setup a Google mail address but you can also use Office365 or Exchange. It’s good 

practice to setup the ‘Allowed sender’ list to prevent unwanted content. 
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Proof of Play 

With proof of play you can generate an overview, per player, of all content shown during a specified time 

frame. With this it’s easy to see how many times a page of playlists has shown during that time in easy to 

read diagrams. It’s also possible to export the data to CSV or Excel. 

 

 

In order to use Proof of Play you need to enable this on every player you wish to log. To do this go to the 

Dashboard -> Player Overview and click on the player you wish to enable: 

 

 

Proof of Play overview is available through: Administration -> Proof of Play   
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Meeting Rooms 

With TDM Digital Signage software it’s possible to create a meeting room solution on any Android tablet 

using Android 6.0 or higher. 

With TDM Meeting Room Solution you can: 

Start Meeting: Arriving at the room you can manually start the meeting. 

End Meeting: Manually end the meeting. For example when the meeting is over soon then expected to free 

up the room. 

Extend Meeting: If the meeting is going to take longer, you can manually extend the time. 

 

Ad-Hoc meeting: Create a meeting on the spot without having to enter it into a calendar 

Find other room: The system will look for any other created meeting rooms to finds an available room. 
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To create a meeting room, click on NEW MEETING ROOM and select the template you wish to use. Give the 

solution a logical name and click save.

 
To add the template to a player and connect a calendar click on the name of the newly created meeting 

room solution. 

Player: Select the player you wish to connect the template to.  

Calendar: Select the Calendar you wish to use.  

Other Rooms: Select a sub calendar (room) to use. With this you can use only one Calendar account and 

create multiple templates for different rooms and connect them to sub calendars. To create a calendar data 

source please refer the section about external data sources. 
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Content Log 

TDM Digital Signage software keeps track of all changes made within TDM. It logs exactly what was changed, 

added or removed, by who and when. With Filter you can track changes made by specific users or to specific 

content. The Content Log is available through: Administration -> Content Log 

 

 

User Management 

When creating a new user there are four different roles that can be assigned to the new user. 

Administrator 

Full control. Access to all functionality. Able to create and manage user accounts 

Power User 

Same functions as a Content Creator with the exception that a Power User is able to create templates. 

Content Creator 

Able to create pages based on templates provided. A content creator is able to add these pages to an existing 

playlist or create a new playlist. A content created cannot add playlists to a presentation 

Display Manager 

Able to create Masterpages, Pages, Playlists and Presentations. Is able to Assign presentations to players and 

create and manage schedules. 
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Available elements  
Below is a list of the elements available in TDM Designer – these are used to create templates and 

master pages.  

 Selection tool   Text element   Image element 

 Video-element   Graphics element  TV-element  

 Website-element  Ticker-(scroll) element  Date-/time-element 

 YouTube-element  Audio stream-element  Slideshow-element 

 Nu24-element   QR-element   PowerPoint-element 

 Vimeo-element 

 

 

Selection tool  
Use the selection tool to select an element from your presentation. 
 

Text element 
Use the text element to add text. The dialogue box will ask you to enter a name (your own 

description) and text. The [Formatting] tab allows you to enter the font, size, colour, style and transparency. 
You can also retrieve the text from an external data source, for example CNN. To do so, click on the ‘Data’ 
tab, and under [External data], select the data source you would like to use. The ‘External data’ section in this 
manual explains how to create data sources. 

 

Image element  
The image element allows you to add images. The dialogue box will ask you to enter a name (your 

own description). On the [Formatting] tab, you can select measurements and transparency; choose whether 
to keep or to change the current ratios; and select the appropriate alignment.  
You can upload one from your computer on the ‘Data’ tab by clicking [Add file(s)]. Once you have added files, 
you must click the [Start upload] button. The image will then appear in your media library. You can also 
retrieve images from an external data source, for example Yahoo Weather. To do so, click on the Data tab, 
and under [External data], select the data source you would like to use. For instructions on how to create 
data sources, check the ‘External data’ section in this manual. 
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Video-element 
The video element allows you to add a video that has been uploaded from your local file, or, 
alternatively, you can insert a Streaming URL in order to display live images of a camera (for 

example). 
You can do this by selecting a video on the ‘Streaming’ tab. The ‘Data’ tab allows you to select or 
upload videos. You can upload videos from your computer on the ‘Data’ tab by clicking on Add file(s). 
Once you have added files, you must click the Start Upload button. The video will then appear in your 
media library. 

 

Graphics element  
Use the graphics element to draw items in your template or master page; it is used, for 

example, to draw a background behind a ticker tape. You can select a colour from the Layout tab. 
 

TV Element (only for Sony Bravias)  
The TV element allows you to feature television channels from your analogue TV tuner in your 

presentation. You can select a channel from the ‘Data’ tab. 
 

Website element  
The website element allows you to display a website. You must enter the complete URL on the 

‘Data’ tab. You can select ‘Reload’ as an additional option; the page will then be refreshed each time. 
 
 
 
 
 

 

Ticker tape element  
The ticker tape element allows you to add a scrolling text overlay (crawler). The dialogue box will ask 

you to enter a name (your own description). The Layout tab allows you to enter the font, size, colour, style 
and transparency. In addition, you also have the option to retrieve the text from an external data source, for 
example NOS [Netherlands Broadcasting Foundation]. To do so, you must click on the ‘Data’ tab and, under 
External data, select the data source you would like to use. To create data sources, you must read the 
instructions contained in the ’External data’ section of this manual. Additionally, you can enter your own text 
in the ‘Data’ tab. 

 

Date/time element  
The date/time element allows you to add a date and/or time. On the Layout tab, enter the font, size, 

colour, style and transparency. The Data tab allows you to select the format, HH:MM:SS or DD-MM-YY. 
 

YouTube element  
The YouTube element allows you to add YouTube videos – for this you require the URL or code for 

your video. For example, you can copy the URL from your browser. You must then paste the YouTube 
code/URL onto the ‘Data’ tab and decide whether you would like to play all or part of the video. 
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Vimeo element 
The Vimeo element allow you to add Vimeo videos. This works the same way as the YouTube 

element. You require the URL or code for your video. You can paste the Vimeo code/URL onto the ‘Data’ tab. 
Unlike the YouTube element you can only play the full duration of the video. 
 

Audio element  
Use the audio element to add single sound files or add an audio stream.  

 
 

Slideshow element  

It's very easy to create an image slideshow using the Slideshow element. By linking to images from 

the image database, you can compile your own image sequence. You can also set the interval between slides 

and choose to make the images semi-transparent.  

NU24 element (only available in the Netherlands) 

The NU24 element makes it easy to embed video content provided by NU.nl. This content is 

available in several different categories (General, Sport, Business, Tech, Entertainment and Weather). Specify 

the frame format in the editor and select the desired category using the drop-down menu. The data is 

externally updated at regular intervals, so that you do not have to do anything yourself after that.  

 

QR-element 
TDM Signage allows you to create QR codes within your templates and pages. Simply select 

the QR element tool and draw the size of your QR element which you prefer. Keep in mind that a QR 
element will always be square; which means you aren’t allowed to change its measurements. Once 
you have placed the element on your template, you now only need to fill in the URL which you want 
to trigger when the QR code is being scanned. 

 

Powerpoint-element 
From within a Masterpage or template you can easily upload your PowerPoint files. TDM will 

automatically detect the number of pages and will ask you if you want to use them as single images 
(by using the slideshow element) or as a video file.  
 

http://nu.nl/
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Masterpages 
 

Master pages are pages containing specific elements, for example a news ticker tape that must 

appear on every page of the presentation. You might describe it as a layer that is applied across all 

the pages of the presentation. An example of the application might include: you would like to use the 

same background using an NOS news ticker tape throughout your presentation. You can then create 

a master page by navigating to [Content > Master pages] in TDM Designer and clicking the New 

masterpage button. 

 

A new screen will now appear, where you can enter the name of your master page and select the 

required resolution. 

 

 

Next, a screen will open on which you can select elements, for example a background image and a 

ticker tape. 
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Templates 
If you are using a pre-defined template, start with step 2; if you would like to create your own (customised) 
template, start with step 1. 
 
Step 1: Creating a template  
In TDM Designer, click ‘Content’ and then ‘Templates’. In the template screen, click on  

New template. 

 

Enter the name of the template you would like to create, select the required resolution and click Save.  
 

 

 

 

The following screen will appear:  
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In the template designer, you can select one of the elements that appear in the menu bar: 
 
If you click on the element you would like to place in the template, use your mouse to start drawing 

in the white window by right-clicking on your mouse and drawing the required dimensions. Once you 

have completed this, a window will open: (we have drawn an image in this example). 

 

You must enter a number of data in the window, including the image name. This name must be 
understandable to you and will not be displayed in the final presentation, only on the overview of elements 
on the left-hand side.  
 

The Layout tab allows you to select a number of options relating to how the element is formatted. 

For images, you have the following options: 

 

• Stretch; Fill: [Ratio is not maintained] 

• Stretch; Uniform: [Ratio is maintained] 

• Stretch; Cover: [Ratio is maintained while filling the entire element] 
 
The option Stretch; Fill is selected by default. 
 
From the ‘Data’ tab, you can select a previously posted image, or, alternatively, you can upload one from 
your computer by clicking New upload. Next, click on the image to select it and then click on Save to insert 
the image. We have added a second image to the example (on the left-hand side), called ‘Image’. 
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Next, in the template we can select, for example, a text element and add this:  

 

 
The template is almost ready for use; we might still choose to add a ticker tape showing news items. As 
explained above, we can use a ticker tape to be used on the master page or we can insert it into this 
template. For now, we are going with the second option. 
 
Click on the ticker tape element and draw a ticker tape in the black bar at the bottom. Next, give the 

element a name, for example ‘News ticker tape.’ On the Formatting tab, select font size 60 (this is 

standard) and the colour white. On the ‘Data’ tab, select NOS and ‘title’ as the column, then click 

Save. The title column from the NOS RSS feed is now displayed, in white and with a font size of 60. 

Click on Save at the top of the page – your template is now ready for use. 
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Pages 
Pages are based on templates. You can use one of the predefined templates for this purpose, or, 

alternatively, you can use a customised template. In this example, we use the “manual” template. To 

create a page, click on Content > Pages in TDM Designer and then on New page. 

  

A screen will appear in which you must enter the name of the new page. In this page we will use the name 
My first page. Select a template and click Save.  
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The next page will open: 

 

 

 

By clicking on an element on the left-hand side, under Elements, you can make changes to your text or 
images. However, you can no longer change the positions of the elements – this is possible only in the 
template. Once you are done editing a page, click Save. 
We would now like to add our page to a playlist; to do this, we need to go to the ‘Playlists’ section. 

Playlists 
Playlists contain pages including information you would like to display on screens. A final 

presentation may contain multiple playlists, for example if you have installed a screen in the cafeteria 

and would like to display the menu along with general information. In that case, you can select a 

playlist containing both general information and menu information, in order to prevent menu 

information from being displayed on screens where it does not belong. To create a playlist and add 

pages, you must click on Content > Playlists in TDM Designer and then on New playlist. 

 

You enter the name of the playlist, select the required resolution and click on Save. 
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A new screen will appear displaying all the pages that are available in the same resolution. 

 

 

Next, click on the page you would like to add, then click on Add to timeline. 

The page will now appear below at the bottom of the timeline. You can select the duration by 

dragging the page on the right-hand side to the right. For example, if you would like to display the 

page on the screen for 20 seconds, you should drag the page (enlarged) to 20 seconds, or, 

alternatively use the ‘-’ and ‘+’ buttons. Once you have added the page(s) required, click Save and 

continue to the ‘Creating presentations’ section.  
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Creating presentations  
You should now have all the ingredients to create a presentation, namely:  
 

• A template  

• A page 

• A playlist  
 
This means we can start creating our presentation. In TDM Designer, click Content > Presentations 
[Content > Presentations] and then on the New presentation button. 

 
 
Enter a name for your presentation and select a resolution. If you have created a master page, select the 
appropriate master page from the menu.  
 

 
 
Next, select a playlist – in our case, this is My first playlist.  

 

Click the  symbol and select a playlist: 
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If you click View pages, you can also set a time schedule – check the ‘Scheduling pages’ section for more 
details. Your content is almost ready for use; all you need to do is link a player or player group.  
 

Assign a player to a presentation 
 

 

To do so, click on the  button above Link player and select the appropriate player or group. 
 
Congratulations, your presentation will now be displayed on your screen! 

 
Scheduling 
TDM Digital Signage software allows you to schedule different presentations on specific times 
and/or days. 
Unlike page or playlist scheduling, scheduled presentations will overrule the default presentation 
for that player.  
It’s even possible to schedule a presentation for different time zones, making sure a 12 o’clock 
scheduling will start the presentation at the same time of day all over the world. 
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To create a new schedule, go to: Content -> Schedules and drag a desired timeframe or double click 
anywhere on the calendar. 

 

 
 
 
 
 
Scheduling pages  
TDM Digital Signage software also allows you to schedule pages – including colleagues’ birthdays, 
special offers, or opening hours. For example: you run a cafeteria and offer a special Wednesday 
afternoon children’s menu. You can then choose to create a page once and have it displayed on 
your screen every Wednesday afternoon. This process is explained below. 
 
Go to the presentation for which you would like to schedule a page in TDM Designer by clicking 
Content > Presentations and click on the ‘pencil’ icon for the presentation for which you would like 
to schedule one or more pages: 

 
Click on the View pages button. 
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Select the page you would like to schedule. A new screen will appear in which you can select the time 

(from/to) date (from/to), and days. In our example, we display this page every Wednesday from 

12:00 p.m. to 1:00 p.m. for the duration of one year. 

 

 

Basic Mode 
IF your usage of signage is limited and are only planning to use a few different pages it is possible to activate 

basic mode. With this mode the creation of templates and playlists is skipped and you are left with pages and 

presentations. Creating a page is the same as creating a template but you won’t have to base a page on a 

template. Instead you can create a page from scratch and move it directly to a presentation.  You will find 

this option anywhere in the Designer in the top right corner of the screen. 
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Although the process is much simpler you will lose the ability to set your house style like you would with 

templates since a page can look like anything the creator wants instead of being limited to the templates 

available. 

 

Deselect Masterpage elements 
When you have certain content, which should be shown full screen, but you have a Masterpage which has 

overlapping elements, you can deselect these Masterpage elements in the second tab next to your 

scheduling option.  
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Config Panel 
 

Once you have set up your initial presentation, there is a series of options in the menu-item “Config Panel” 

you can use for more advanced functions. 

The config panel allows the administrator(s) to setup the Designer with the exact specification they like or 

the other users need. It is accessible from the top menu, only to users that have administrator rights.  

Clicking it opens a collection of editable options, which you can tweak/alter to configure the Designer to your 

liking: 

- Players: 

The Players menu shows you an overview of your players. You can check player names, licenses and status in 

here. Also, you can create groups of players or set alerts for when a player goes offline. 

When clicking the player name, a popup comes up that looks like this for the PC player: 

 

 

 

 

 

 

 

 



 

                                                                         
 

 

34 
 

And has a little less options for the HTML5/Android player: 

 

 

In here, you can alter a player’s name, assign one of your licenses to it, or add it to a group you’ve created. 

(Group creation is on the right of the page before the popup. Just enter a name for your group, save it, and 

your group shows up right in the menu when you click your player.) 

 

 

 

In case you have a Windows version, you can also select the Updates tab: 

 

This tab allows you to select whether or not you wish your players to automatically update to a newer 

version of the software, when it comes available. Also, you can push an old version of the software if need 

be.  
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The next tab is the Info tab: 

 

This tab shows you information on the current version of the player software you are using, but also of the 

version of our File sync service and the Update service. Also, the UID for the player is shown. This might 

prove helpful in case your reseller needs to provide you with support.  

 

The next tab is Advanced: 

 

In this tab you can activate the High-Quality Tickertape for the player. This is a more CPU intensive tickertape 

but supports functionality like transparency. Select this option as well if you have any DirextX issues. 
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The last tab is the Sony IP control tab: 

 

Here you can setup Sony IP control. For use with the PC software you will need to download and install the 

additional IP control software which can be found under Administration -> Downloads. 
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Alerts 
There is an Alerts button to the top right of your player overview. If you click it, you see something like this: 

 

Right here, you can enter an e-mail address to which you would like to receive alerts when your players go 

offline or encounter a problem. To the right on this page, you can specify a specific range of dates for which 

you don’t want e-mails to be sent: 
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Resolutions:  
 

The Resolutions menu lets you add and/or remove any resolutions to or from the Designer. 

It looks like this: 

 

When you click “Add resolution”, you will be presented with this screen: 

 

 

Fill out the width and height you need for your presentation, click Save and you will be able to use your 

newly created resolution right away. 

 

Keep in mind that you can also delete resolutions, but never one that is used in one of your templates. You 

will receive a notification when you try to do so.   
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Elements: 

 
This is what you see when you click the Elements menu: 

 

It allows you to enable or disable the option to create new elements of a specific kind to administrators and 

display managers. 

A green bar under the element indicates that the user is free to use this element at a template/masterpage 

level.  

A red bar, like in the example below, shows that the user may not use this element. Please note that when 

disabling an element that is already in a template, the user will still be able to edit the element, but not 

create new ones of that kind.  

 

 

In this example, the user cannot create these new elements: Web, Ticker, Slideshow, and PowerPoint.  

 

NU24: 
This item allows our Dutch users to choose the times at which their player checks for and downloads new 

NU24 news videos. By ticking the boxes, you select the preferred times.  

Default Page Duration: 
The default page duration is set in this menu. You can change both the default time for your regular pages, as 

well as for your touch pages.  

The options look like this: 
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Both times are set at 10 seconds by default, but anyone with administrator rights is free to change the 

duration. Also, please keep in mind that anyone that is able to edit a playlist can alter page duration for every 

page specific. When a page holds one of the following elements, the page duration is overruled by the 

duration of the content: Video, Youtube-video, Slideshow, NU24. 
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RS232 control and schedules 
If your player and display have RS232 ports, you can use those to send commands from the Designer to the 

player. The specific commands differ from manufacturer and per model, so there is no standard set op 

commands, however, most manufacturers offer at least switching on and off and some basic commands. 

 

In order to set it up, you will first need to install TDM RS232 Service 1.0.0.0, which you can download from 

the Designer. This service should run on the machine that is connected via RS232.  

Once that is installed, you can add your schedule by clicking the plus to the left, next to “RS232 commands”. 

In the screen that appears next, please fill out your command (use hexadecimal values) and name it: 

 

Next, set up your schedule: 

 
 

http://upload.tdmsignage.nl/upload/RS232ServiceInstaller.msi
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In the tab General, you can select the days you wish for 

your schedule to be active by ticking the boxes. In the time 

field, you can set the time at which you want your schedule 

to become active and just below that, you can select either 

the “Display on” or “Display off” command. Next, please 

tick the Active box. Next, on the Players tab, you can select 

the players that will be affected by this: 

An example RS232 schedule looks like this: 

 

In this particular case, the players, to which this schedule is assigned, power on every Sunday, Wednesday 

and Saturday at 2pm.  
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TV Scheduling: 
Some displays (currently only Sony displays) can be controlled via IP control. You can then for example power 

on or off a display by making a schedule: 

 

For Sony Bravia displays not using the Android app, the steps to follow are these: 

- On the page Administration -> Players you need to enter an internal IP address (in case you want to host 

the Scheduling service internally, available on the downloads page) or an external IP address and port 

number (TDM will send the schedule from the cloud, your firewall needs to be configured) at the specific 

player. You also need to enter the password you set up at your TV screen in the next step. 

- On the TV screen you need to enter the Hotel Mode Settings and in the IP Control -> Authentication -> Pre-

Shared Key section you need to enter the same password as in the step before. Also, in the section IP Control 

-> Simple IP Control you need to set this option to On. 

- If you wish to host the scheduling software internally, you need to enter your customer key during 

installation. You can find your customer key on the Administration page in the Registration details section. 

The software is available on the Administration -> downloads page. 

 

For Bravia’s that use our Android app, you can skip these steps and just connect your player to the schedule 

you entered as there is no need to configure an IP-address for that.  
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Setting up a schedule is easy. Click the plus to the top right and a popup appears: 

 

In the tab General, you can select the days you wish for your schedule to be active by ticking the boxes. In 

the time field, you can set the time at which you want your schedule to become active and just below that, 

you can select either the “Display on” or “Display off” command. Next, please tick the Active box. Next, on 

the Players tab, you can select the players that will be affected by this: 

 
An example schedule would look like this: 
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The schedule above powers the screen on at 7am every day of the week (the top schedule) and at 6pm, the 

display is switched off (bottom schedule). 

External Data: 
For external data, you can provide feeds of external sources, including RSS feeds, XML feeds or Twitter feeds. 
RSS feeds are often used to provide content for third-party programs without formatting. You might also 
have an HR package that lists your employees’ birthdays in XML, allowing you to easily display data on your 
screen.  
 
To add a feed click New datasource in the top right of this tab.  

 

 

In this example, we will add an RSS feed from CNN (http://rss.cnn.com/rss/edition_world.rss). 

First, we name our datasource and then select RSS/XML: 

 

 

 

 

 

 

 

 

 

 

 

 

http://rss.cnn.com/rss/edition_world.rss
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Click Next and the following appears: 

 

Fill out the URL for your RSS/XML feed. Should the feed require Windows authentication, you can also fill out 

the username and password here.  

When you are done, click Save. 

The external datasource is now set up and appears in your overview now: 

 
From here, you can click the icons in front of the feed to do edit your feed: 

Edit: Lets you view and/or edit what you have entered in the above steps. 

Delete: Deletes your datasource from the Designer. 

View: Opens a new browser tab to show you the data in the specific feed. 

Modify: Lets you replace text from your datasource to another value you want. 

 

 

An example for this would be a feed that shows the day of the week in English (Wednesday), but you want to 

show it in German (Mittwoch). In the left field, you would have Wednesday, to the right would be Mittwoch.  
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Exchange 
click on the button “new data source” to add a new data source. 

In the new window Fill in a name for your data source, click on Exchange and click on the “next” button. 

In the next window fill out the username and password you want to use to connect.  

 

The Exchange URL needs to point to the exchange.asmx file of the Exchange server. This URL usually looks 

something like: https://exchange.server.com/ews/exchange.asmx 

In the dropdown menu you can select to either use a calendar from the user or if you want to use a Room 

resource. After selecting the desired type press save 

If you select calendars, select your desired calendar in the new window and press save again. 

 

 

 

 

 

 

 

https://exchange.server.com/ews/exchange.asmx
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If you selected Rooms, fill in the address for the room resource and press save. 

 

You have now successfully created your data source. 

 

Office 365 
Click on the button “new data source” to add a new data source.   

In the new window Fill in a name for your data source, click on Office 365 Calendar and click on the “next” 

button. 

In the next window fill out your username and password you want to use to connect.  

In the dropdown menu you can select to either use a calendar from the user or if you want to use a Room 

resource. After selecting the desired type press save  

If you select calendars, select your desired calendar in the new window and press save again  

If you selected Rooms, fill in the address for the room resource and press save  

 

You have now successfully created your data source. 
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Google Calendar 
The first step is to create a Client ID and Secret. To do this go to: 

https://console.developers.google.com/flows/enableapi?apiid=calendar 

Select create a project and Agree and continue 

In the next screen click on “Go to Credentials”. 

In the “Add credentials to your project” menu select for the API “Google calendar API”, for “were will you be 

calling the API from” select Web Server, and for “what data will you be accessing” select user data. 

Afterwards click on the blue button 

In the “Create an OAuth 2.0 client ID” fill out a desired Name. In “Authorized Redirect URLs” enter the 

following URL: https://designer.tdmsignage.com/4.0/authenticate (if you are using on older version you 

must change 4.0 to the version you use, i.e. 3.7) If you get a redirect url mismatch, please make sure you are 

logging in on https:// instead of http:// 

Click on “Create OAuth Client ID” 

In this step choose your Email address and give your product a name  

In the new windows click on your Created client to open the information. The next window will show your 

Client ID and secret, save this information. 

 

Click on the button “new data source” to add a new data source.  

In the new window Fill in a name for your data source, click on Google Calendar and click on the “next” 

button. 

In the next window fill out your client ID and Secret. And click save. 

 

In the pop-up window log in with your google account and allow the message. 

In the next window Select your desired calendar(s) and the amount of days to show. Afterwards click on 

Save. 

You’ve now successfully created your Google calendar data source. 

 

https://designer.tdmsignage.com/4.0/authenticate
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Preview Size 
It is possible to configure the size of the preview screen within the designer. You can specify the max 

width/height for the preview window. Depending on the orientation of the presentation (horizontal or 

vertical) the max width or height is reached first.  

You can specify a value ranging from 300px till 1920px. 

 

 

Authentication Options 
Here you can enable 2FA for all users. This will use the Google Authenticator. After enabling this setting all 

users will get the option to setup Google Authenticator when logging in for the first time after enabling. 
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Upload fonts 
You can upload you own custom fonts to TDM using this panel. You can upload True Type Fonts as well as 

Open Type Fonts. In some cases, the .EOT extension is needed as well. Please note that when using a PC 

Player license the font needs to be installed in Windows on the player as well. 

Simply drag your files to the upload window on the right-hand side of the screen or use the ‘Add files’ button 

to select the files through a File Explorer. 

 

Support 
After reading this manual, you should be able to create a complete presentation and broadcast this on your 
screens. Our website also contains answers to Frequently Asked Questions (FAQ). 
 
If you require additional support, we will be pleased to assist you from Monday to Friday from 9:00 

a.m. to 5:00 p.m. at telephone number +31 20 2610985 or by e-mail at support@tdmsignage.nl. 

 

 

 

 


